Últimos temas
» Hola os enseño mi primer videojuego que hice
por nekoman Hoy a las 6:16 am

» Project Moon - Reclutamiento - RPGM2k3
por sd0wz117 Ayer a las 8:06 pm

» [XP] THE LEGEND OF THE CROWNS: Looking Across the Time
por Fiquei Ayer a las 12:03 pm

» Heroe Retirado
por sipsop Vie Jun 22, 2018 5:23 am

» Utilizar imagen como mapa
por MoonSoldierMx Jue Jun 21, 2018 6:41 am

» [Resultados] Mote al limo del foro
por Alojzy Jue Jun 21, 2018 12:28 am

» Laminación [VXACE]
por Pocari Miér Jun 20, 2018 10:09 am

» Piedra, papel, tijera, lagarto, spock
por Naitsirc Lun Jun 18, 2018 9:33 pm

» Buenas tengo duda por publicar un juego
por Turbiosoft.acho Lun Jun 18, 2018 8:40 pm

» Hola doy ha conocer como sera mi juego
por nekoman Dom Jun 17, 2018 9:59 pm

» [COMPLETO][MV] Ve por ella.
por nekoman Sáb Jun 16, 2018 5:52 pm

» The Legend of Zelda: Trident of Power (RPGM2003)
por aetherventus258 Vie Jun 15, 2018 7:16 pm


Problemas con animacion del RPGMAKER VM

Ir abajo

Problemas con animacion del RPGMAKER VM

Mensaje por redwolf el Lun Nov 30, 2015 10:30 pm

Señoraaaa, ha llegado el cansinoooo  Very Happy
A ver si pueden ayudarme con este problema 
He creado una animacion de combate con los recursos basicos. cuando pruebo en el simulador no pasa nada, pero cuando la pongo en el juego, este se congela con el siguiente error: 
TypeError
Cannot read properly '0' of null

redwolf
PJ de Relleno
PJ de Relleno

España
RPG Maker : MV
Mensajes : 13
Monedas : 28
Reputación : 1

Volver arriba Ir abajo

Re: Problemas con animacion del RPGMAKER VM

Mensaje por JapoZero el Mar Dic 01, 2015 10:25 pm

¿Qué scripts estás utilizando en el juego?
¿A qué le añadiste la animación (espada, técnica, u objeto)?
Si es posible, mandame una imagen del editor en la pestaña de lo que utiliza para ver si hay algo raro que pueda causar el error.
Trata tambien si es posible de probar la animación en un evento de mapa para ver si funciona en ese caso.
Salu2
avatar
JapoZero
PJ Principal
PJ Principal

Masculino
Chile
RPG Maker : Ace
Mensajes : 651
Monedas : 3500
Reputación : 255
Edad : 18
Localización : Chile

Volver arriba Ir abajo

Re: Problemas con animacion del RPGMAKER VM

Mensaje por redwolf el Miér Dic 02, 2015 1:04 pm

es el básico, no he metido nada, ya que es un juego para probar las posibilidades con el Vm, siempre que adquiero uno hago esto. y se que es animación debido a que si pongo una de juego funciona bien, 
Es un Item que al ser usado desde Objeto en batalla hace 600- B.def*2 (simplemente como info) 
Cuando la pruebo en el menu animacion va bien, 
pero cuando lo hago en batalla no tanto. 
Creo que te pondre algo mejor que una foto.
Spoiler:
 




View My Video



 


Última edición por redwolf el Miér Dic 02, 2015 1:35 pm, editado 2 veces

redwolf
PJ de Relleno
PJ de Relleno

España
RPG Maker : MV
Mensajes : 13
Monedas : 28
Reputación : 1

Volver arriba Ir abajo

Re: Problemas con animacion del RPGMAKER VM

Mensaje por JKLmaster el Miér Dic 02, 2015 1:27 pm

Cuando pruebes presiona F8, ahi te va a salir donde fue que se genero el error, eso puede ayudar a saber que esta fallando.
avatar
JKLmaster
PJ Principal
PJ Principal

RPG Maker : MV
Mensajes : 188
Monedas : 1669
Reputación : 56

Volver arriba Ir abajo

Re: Problemas con animacion del RPGMAKER VM

Mensaje por redwolf el Miér Dic 02, 2015 1:38 pm

Eso del F8 no lo sabia, edite mi mensaje anterior para que vierais dos imagenes y un video 
pongo aqui mi error 
Spoiler:

TypeError: Cannot read property '0' of null
    at Sprite_Animation.updateCellSprite (file:///C:/Users/Red/Documents/Games/Redwolf%20tale%204/js/rpg_sprites.js:1407:23)
    at Sprite_Animation.updateAllCellSprites (file:///C:/Users/Red/Documents/Games/Redwolf%20tale%204/js/rpg_sprites.js:1399:18)
    at Sprite_Animation.updateFrame (file:///C:/Users/Red/Documents/Games/Redwolf%20tale%204/js/rpg_sprites.js:1381:14)
    at Sprite_Animation.updateMain (file:///C:/Users/Red/Documents/Games/Redwolf%20tale%204/js/rpg_sprites.js:1351:22)
    at Sprite_Animation.update (file:///C:/Users/Red/Documents/Games/Redwolf%20tale%204/js/rpg_sprites.js:1235:10)
    at file:///C:/Users/Red/Documents/Games/Redwolf%20tale%204/js/rpg_core.js:3290:19
    at Array.forEach (native)
    at Sprite.update (file:///C:/Users/Red/Documents/Games/Redwolf%20tale%204/js/rpg_core.js:3288:19)
    at file:///C:/Users/Red/Documents/Games/Redwolf%20tale%204/js/rpg_core.js:3290:19
    at Array.forEach (native)

redwolf
PJ de Relleno
PJ de Relleno

España
RPG Maker : MV
Mensajes : 13
Monedas : 28
Reputación : 1

Volver arriba Ir abajo

Re: Problemas con animacion del RPGMAKER VM

Mensaje por JKLmaster el Miér Dic 02, 2015 1:54 pm

Probablemente copiaste la animación, que usaba dos archivos de imágenes y quitaste uno, pero no borraste las imágenes que la animación usaba del segundo archivo de imágenes. Entonces al reproducir la animación busca la imagen que esta en el segundo archivo pero al no existir un segundo archivo en la animación copia, da el error.
avatar
JKLmaster
PJ Principal
PJ Principal

RPG Maker : MV
Mensajes : 188
Monedas : 1669
Reputación : 56

Volver arriba Ir abajo

Re: Problemas con animacion del RPGMAKER VM

Mensaje por redwolf el Miér Dic 02, 2015 2:09 pm

No se como, pero pace que JKL tenia razon, He borrado la animacion y la he vuelto a crear de 0 ahora si funciona, Duda solucionada. 
Jefe, puedes cerrar el tema.

redwolf
PJ de Relleno
PJ de Relleno

España
RPG Maker : MV
Mensajes : 13
Monedas : 28
Reputación : 1

Volver arriba Ir abajo

Re: Problemas con animacion del RPGMAKER VM

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.