Últimos temas
» Batallas Pokemon
por maxlobo Hoy a las 7:47 am

» Complecsua
por MoonSoldierMx Ayer a las 12:20 am

» Readvin 1 y 2
por Muzgar Dom Nov 19, 2017 7:42 pm

» Busco ayuda para mi juego, no importa la edad
por Muzgar Dom Nov 19, 2017 3:16 pm

» [VXACE] Las Esferas de Capricornia. Actualizado 17.11.17
por Pocari Dom Nov 19, 2017 12:31 am

» [Vx/Ace] Pack Bioma de Miel
por YggdrasilHerald Vie Nov 17, 2017 4:00 am

» La Historia Infinita (DEMO)
por Chaskarron Miér Nov 15, 2017 12:36 am

» [MV+Completo]Al Ataque - Derrotemos a nuestros enemigos
por hikarukurenai Mar Nov 14, 2017 8:07 pm

» Dekar Chronicles
por KRiZaLiD Mar Nov 14, 2017 7:43 pm

» [Sugerencia] Buenas practicas
por Alojzy Lun Nov 13, 2017 9:56 pm

» [Ace]Script día/noche + reloj
por JAMSDream Dom Nov 12, 2017 1:52 am

» "La tribu" demo
por Chaskarron Vie Nov 10, 2017 10:57 pm


Problemas con animacion del RPGMAKER VM

Ver el tema anterior Ver el tema siguiente Ir abajo

Problemas con animacion del RPGMAKER VM

Mensaje por redwolf el Lun Nov 30, 2015 10:30 pm

Señoraaaa, ha llegado el cansinoooo  Very Happy
A ver si pueden ayudarme con este problema 
He creado una animacion de combate con los recursos basicos. cuando pruebo en el simulador no pasa nada, pero cuando la pongo en el juego, este se congela con el siguiente error: 
TypeError
Cannot read properly '0' of null

redwolf
PJ de Relleno
PJ de Relleno

España
RPG Maker : MV
Mensajes : 13
Monedas : 28
Reputación : 1

Volver arriba Ir abajo

Re: Problemas con animacion del RPGMAKER VM

Mensaje por JapoZero el Mar Dic 01, 2015 10:25 pm

¿Qué scripts estás utilizando en el juego?
¿A qué le añadiste la animación (espada, técnica, u objeto)?
Si es posible, mandame una imagen del editor en la pestaña de lo que utiliza para ver si hay algo raro que pueda causar el error.
Trata tambien si es posible de probar la animación en un evento de mapa para ver si funciona en ese caso.
Salu2
avatar
JapoZero
PJ Principal
PJ Principal

Masculino
Chile
RPG Maker : Ace
Mensajes : 645
Monedas : 3720
Reputación : 240
Edad : 17
Localización : Chile

Volver arriba Ir abajo

Re: Problemas con animacion del RPGMAKER VM

Mensaje por redwolf el Miér Dic 02, 2015 1:04 pm

es el básico, no he metido nada, ya que es un juego para probar las posibilidades con el Vm, siempre que adquiero uno hago esto. y se que es animación debido a que si pongo una de juego funciona bien, 
Es un Item que al ser usado desde Objeto en batalla hace 600- B.def*2 (simplemente como info) 
Cuando la pruebo en el menu animacion va bien, 
pero cuando lo hago en batalla no tanto. 
Creo que te pondre algo mejor que una foto.
Spoiler:


Última edición por redwolf el Miér Dic 02, 2015 1:35 pm, editado 2 veces

redwolf
PJ de Relleno
PJ de Relleno

España
RPG Maker : MV
Mensajes : 13
Monedas : 28
Reputación : 1

Volver arriba Ir abajo

Re: Problemas con animacion del RPGMAKER VM

Mensaje por JKLmaster el Miér Dic 02, 2015 1:27 pm

Cuando pruebes presiona F8, ahi te va a salir donde fue que se genero el error, eso puede ayudar a saber que esta fallando.
avatar
JKLmaster
PJ Principal
PJ Principal

RPG Maker : MV
Mensajes : 182
Monedas : 1508
Reputación : 51

Volver arriba Ir abajo

Re: Problemas con animacion del RPGMAKER VM

Mensaje por redwolf el Miér Dic 02, 2015 1:38 pm

Eso del F8 no lo sabia, edite mi mensaje anterior para que vierais dos imagenes y un video 
pongo aqui mi error 
Spoiler:

TypeError: Cannot read property '0' of null
    at Sprite_Animation.updateCellSprite (file:///C:/Users/Red/Documents/Games/Redwolf%20tale%204/js/rpg_sprites.js:1407:23)
    at Sprite_Animation.updateAllCellSprites (file:///C:/Users/Red/Documents/Games/Redwolf%20tale%204/js/rpg_sprites.js:1399:18)
    at Sprite_Animation.updateFrame (file:///C:/Users/Red/Documents/Games/Redwolf%20tale%204/js/rpg_sprites.js:1381:14)
    at Sprite_Animation.updateMain (file:///C:/Users/Red/Documents/Games/Redwolf%20tale%204/js/rpg_sprites.js:1351:22)
    at Sprite_Animation.update (file:///C:/Users/Red/Documents/Games/Redwolf%20tale%204/js/rpg_sprites.js:1235:10)
    at file:///C:/Users/Red/Documents/Games/Redwolf%20tale%204/js/rpg_core.js:3290:19
    at Array.forEach (native)
    at Sprite.update (file:///C:/Users/Red/Documents/Games/Redwolf%20tale%204/js/rpg_core.js:3288:19)
    at file:///C:/Users/Red/Documents/Games/Redwolf%20tale%204/js/rpg_core.js:3290:19
    at Array.forEach (native)

redwolf
PJ de Relleno
PJ de Relleno

España
RPG Maker : MV
Mensajes : 13
Monedas : 28
Reputación : 1

Volver arriba Ir abajo

Re: Problemas con animacion del RPGMAKER VM

Mensaje por JKLmaster el Miér Dic 02, 2015 1:54 pm

Probablemente copiaste la animación, que usaba dos archivos de imágenes y quitaste uno, pero no borraste las imágenes que la animación usaba del segundo archivo de imágenes. Entonces al reproducir la animación busca la imagen que esta en el segundo archivo pero al no existir un segundo archivo en la animación copia, da el error.
avatar
JKLmaster
PJ Principal
PJ Principal

RPG Maker : MV
Mensajes : 182
Monedas : 1508
Reputación : 51

Volver arriba Ir abajo

Re: Problemas con animacion del RPGMAKER VM

Mensaje por redwolf el Miér Dic 02, 2015 2:09 pm

No se como, pero pace que JKL tenia razon, He borrado la animacion y la he vuelto a crear de 0 ahora si funciona, Duda solucionada. 
Jefe, puedes cerrar el tema.

redwolf
PJ de Relleno
PJ de Relleno

España
RPG Maker : MV
Mensajes : 13
Monedas : 28
Reputación : 1

Volver arriba Ir abajo

Re: Problemas con animacion del RPGMAKER VM

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.