Últimos temas
» Proyecto Cristal [MV]
por Rafaxter Ayer a las 8:22 pm

» Al acabar los PM que se ponga el estado "x"
por Pokefanmati Dom Jul 23, 2017 7:58 pm

» [ACE] La Aventura de Sonik
por Sonik Sáb Jul 22, 2017 11:57 pm

» [XP] Engine de Terreno de Calayax
por Calayax Sáb Jul 22, 2017 1:40 am

» Taller del BGM
por ZororoWhite Vie Jul 21, 2017 12:48 pm

» Concurso de screens - Mayo/Junio 2017 [Resultados]
por ZororoWhite Vie Jul 21, 2017 12:44 pm

» Ayuda cob Interruptores
por KRiZaLiD Vie Jul 21, 2017 7:02 am

» Ayuda - Quitar opción de atravesar todo RPG VX ACE
por KRiZaLiD Vie Jul 21, 2017 6:57 am

» KUnits XP 2017
por kyonides Vie Jul 21, 2017 5:37 am

» Evento Comunes...todavía no la cazo bien con algo
por Calayax Jue Jul 20, 2017 8:50 pm

» Guía de trucos para ACE
por Pokefanmati Jue Jul 20, 2017 8:03 am

» Que el personaje desaparezca al usar habilidad [ayuda] [MV]
por Dream Jue Jul 20, 2017 5:53 am


Problema con el comando "robar"

Ver el tema anterior Ver el tema siguiente Ir abajo

Problema con el comando "robar"

Mensaje por Mogsonikku el Vie Oct 21, 2016 2:47 am

Muy buenas a todos! Empece hace poco un nuevo proyecto, en el cual la protagonista es una ladrona, y claro, todo ladrón tiene que robar, así que me puse a investigar y encontré un vídeo en ingles en el que explicaba como hacerlo, y lo conseguí, pero me ocurre un problema.
El pj empieza en un área en el que aparece un solo enemigo, al que se le puede robar una poción, se le roba y después lo derroto, pero después, al aparecerme otro encuentro con el mismo monstruo me dice que ya no se le puede robar, como si fuera el mismo monstruo al que le robe antes. Sabéis alguna manera de que esto no pase?
Muchas gracias de antemano y espero haberme explicado bien xD

Mogsonikku
PJ de Relleno
PJ de Relleno

España
RPG Maker : Ace
Mensajes : 5
Monedas : 9
Reputación : 0

Volver arriba Ir abajo

Re: Problema con el comando "robar"

Mensaje por Muzgar el Vie Oct 21, 2016 11:01 am

Bueno antes que nada... una de las cosas que deberías hacer es enseñarnos cómo lo hiciste. Diciendo "encontré un vídeo en inglés que me explicaba como hacerlo" no nos ayudas xD Piensa que esto es como las matemáticas. Hay muchas formas de conseguir el mismo resultado. 2+2=4 pero también 2*2=4 e incluso 6-2=4 pero no es lo mismo. Pues esto es lo mismo, es posible que lo hayas hecho con engines, o por evento común o por script... hay muchas formas de hacerlo y si no nos dices cómo lo haces no podemos saber qué falla xD

Ahora bien ante la falta de información te propongo otra solución... Un script para robar. No lo he usado ya que no utilizo el Ace para mis proyectos, pero siendo de Yanfly debería estar bien sin problemas y ya que dices que viste un tutorial en inglés daré por supuesto que entiendes el inglés xD también daré por supuesto que lo buscas para "Ace" ya que tienes el simbolo de esta plataforma.

Espero que te sirva, si no pues comentanoslo.

Un saludo

_________________
Apoya wild wars poniendo esta barra en tu firma


Muzgar apoya a...
Spoiler:

avatar
Muzgar
Admin
Admin

RPG Maker : Ace
Mensajes : 973
Monedas : 805
Reputación : 105

Volver arriba Ir abajo

Re: Problema con el comando "robar"

Mensaje por Mogsonikku el Vie Oct 21, 2016 1:21 pm

Gracias por responder! Pues mira os enlazo el video para que veais como lo hice, y bueno de ingles no controlo mucho, la verdad es que segui los pasos has ta qeu me salio xd
https://www.youtube.com/watch?v=eRWcey5q0T4&t=294s

Mogsonikku
PJ de Relleno
PJ de Relleno

España
RPG Maker : Ace
Mensajes : 5
Monedas : 9
Reputación : 0

Volver arriba Ir abajo

Re: Problema con el comando "robar"

Mensaje por Muzgar el Vie Oct 21, 2016 11:38 pm

Te recomiendo que uses el script que te he pasado para evitar problemas.

Ahora bien... sobre el video por lo que he visto el problema es que cuando consigues robar algo activa un interruptor pero nunca se desactiva. Tendrías que desactivarlo de alguna forma por que si no te pasa eso, cuando empieces otro combate el interruptor estará activado y por lo tanto te lo tomará como que ya está robado así que  si lo desactivas ya lo tendrías. Lo malo es que no se me ocurre ni una forma aparte de que básicamente pongas en cada mapa que hagas un evento en paralelo desactivando continuamente el interruptor, así cada vez que termines el combate lo desactives (Llevo demasiado tiempo sin tocar el Maker así que no se me ocurren muchas cosas más ahora mismo xD)

De todas formas insisto que seguramente con el script te ahorres mucho trabajo, si aún así sigues queriendo hacerlo por engines (a la cual a la larga cuantos menos uses mejor por que tener muchos activados provoca lag) la solución a tu problema sería eso, desactivando el interruptor. La mejor forma que puedes comprobar que es esto es haciendo un combate, robas el objeto, creas un evento/NPC que desactive el interruptor y vuelve a combatir para ver si se ha solucionado. Si es así es por esto y lo único que te quedaría sería buscar la forma de desactivarlo tras cada combate xD

Espero que te haya servido la ayuda y si no... coméntamelo.

Un saludo, suerte!

P.D: Por si acaso aclaro que el interruptor del que hablo es el de "Theft succeeds" el segundo.

_________________
Apoya wild wars poniendo esta barra en tu firma


Muzgar apoya a...
Spoiler:

avatar
Muzgar
Admin
Admin

RPG Maker : Ace
Mensajes : 973
Monedas : 805
Reputación : 105

Volver arriba Ir abajo

Re: Problema con el comando "robar"

Mensaje por Mogsonikku el Sáb Oct 22, 2016 1:52 am

gracias por los consejos, pero aun a riesgo de parecer un noob, no se muy bien como van los scripts por eso no me atreví a usarlo jajaaja, todo lo que sea codigo me de miedo jajaja, pero voy a intentarlo a ver si hay suerte

Mogsonikku
PJ de Relleno
PJ de Relleno

España
RPG Maker : Ace
Mensajes : 5
Monedas : 9
Reputación : 0

Volver arriba Ir abajo

Re: Problema con el comando "robar"

Mensaje por Muzgar el Dom Oct 23, 2016 1:46 pm

Perdón por no contestar antes,a ver... todos fuimos "noobs" en algún momento, es normal y no pasa absolutamente nada. Estamos aquí justo para ayudar y enseñar a la gente que está empezando así que no te preocupes por ello, cualquier duda avisanos y listo.

Para instalar scripts es muy sencillo, vas al editor de scripts al lado del administrador de recursos en la barra de arriba (O pulsa F11) ahí te aparecerán todos los scripts del juego, vas abajo de todo donde pone "Materials" pues debajo de este le das a click derecho "insertar" y pegas el script ahí.

Algunos scripts suelen funcionar simplemente haciendo eso, otros en cambio necesitas hacer cosas a mayores. Lo normal es que dentro del propio script te vengan las instrucciones de uso. En este caso en concreto simplemente tienes que pegar y luego tienes que "configurar al enemigo" utilizando los comandos que te dan y aparecen en las imagenes en las notas de los enemigos.

Cualquier cosa aquí estamos.

Un saludo

_________________
Apoya wild wars poniendo esta barra en tu firma


Muzgar apoya a...
Spoiler:

avatar
Muzgar
Admin
Admin

RPG Maker : Ace
Mensajes : 973
Monedas : 805
Reputación : 105

Volver arriba Ir abajo

Re: Problema con el comando "robar"

Mensaje por Mogsonikku el Lun Oct 24, 2016 8:26 pm

Muchas gracias por todo! Gracias a los scripts al final lo he conseguido, era más fácil de lo que parecía xD. 
MIl gracias!!

Mogsonikku
PJ de Relleno
PJ de Relleno

España
RPG Maker : Ace
Mensajes : 5
Monedas : 9
Reputación : 0

Volver arriba Ir abajo

Re: Problema con el comando "robar"

Mensaje por Contenido patrocinado


Contenido patrocinado


Volver arriba Ir abajo

Ver el tema anterior Ver el tema siguiente Volver arriba

- Temas similares

 
Permisos de este foro:
No puedes responder a temas en este foro.